HELP! Flame Out

Fastfreight

New member
Joined
Nov 12, 2023
Messages
5
Reaction score
4
Points
3
Location
Southern Vermont
Grill
Smokefire EX4
New to this forum … Have an EX4 that has been working flawlessly for two years and suddenly having repeated flame outs … Customer service is trying to help but still happening … I use Lumberjack pellets and keep them warm dry … I know other folks must have had this problem .. wondering what you did to correct it
 
The usual culprits are finger guard not removed, clean auger and chute and clean burn pot before cook. I would assume Weber has done all three of these corrections with you. I have found it helpful to check the hopper every time I turn or baste the meat just to make sure the chute portion of the hopper is full.
 
Thanks for your feedback ... the grid at the bottom of the burn pot seems to have been the problem...it was warped and starting to disintegrate ...Weber sent me a whole new assembly and things seem to be back to normal ... knock on wood :)
 
Thanks for your feedback ... the grid at the bottom of the burn pot seems to have been the problem...it was warped and starting to disintegrate ...Weber sent me a whole new assembly and things seem to be back to normal ... knock on wood :)
Great. I have had mine replaced once. After Thanksgiving I am going to ask Weber to replace most of the internal parts. Most are rusting through. I use my EX6 about 3 times a week. Today I am doing a brisket for tomorrow.
 

Attachments

  • 20231122_072637.jpg
    20231122_072637.jpg
    535.5 KB · Views: 8
My fire pot grate rusted away too. Hope that resolves it for you. I‘d agree with OGauge4Me on other possible causes. Definitely pull the auger out occasionally especially if your pellets have lot of dust.
 
My fire pot grate rusted away too. Hope that resolves it for you. I‘d agree with OGauge4Me on other possible causes. Definitely pull the auger out occasionally especially if your pellets have lot of dust.
Thanks…The new grate and burn pot seem to have done the trick … everything is back to normal … I think just the grate would have been enough but they sent me the whole assembly so I put it in
 
Thanks…The new grate and burn pot seem to have done the trick … everything is back to normal … I think just the grate would have been enough but they sent me the whole assembly so I put it in
Were the screws holding in the assembly easy to remove?
 
Were the screws holding in the assembly easy to remove?
There are no screws holding the assembly in .... it just lifts out....you put the grate where it belongs and then put the burn pot back down over the top ... nothing to it ... Just make sure the end of the glow plug is through the little hole in the grate
 
Back
Top