New controller wont connect or pair

JYD-BBQ

Active member
Joined
Mar 1, 2020
Messages
97
Reaction score
169
Points
33
Location
West Islip, NY
The original controller on EX-6 went bad, finally had a chance to install the new one. The new controller was set at 4042 but the software is 1683. The new one will not connect to the WiFi and I cannot pair using Bluetooth. I tried forgetting the device in the app and a factory reset but nothing worked and nothing shows up on the screen indicating WiFi signal or Bluetooth. I called Weber but they are closed for Christmas. Could this be another faulty controller ?

I never had any issue connecting or updating with the original controller. Any suggestions would be appreciated !!

Thanks
 
Sounds like a bluetooth issue. The only thing I can think of is to delete the app and reinstall then try pairing. Or use a different device like an iPad? Worth a shot. Merry Christmas.
 
Sounds like a bluetooth issue. The only thing I can think of is to delete the app and reinstall then try pairing. Or use a different device like an iPad? Worth a shot. Merry Christmas.
Thanks, I was trying with my android. I will get my wife's I phone and give it a try,
 
Thanks, I was trying with my android. I will get my wife's I phone and give it a try,
I frequently have had issues with my Android either not pairing correctly or not updating the SmokeFire completely. When that happens I forget the SF on my Weber connect and the reconnect and pair with my iPad. That has always solved the problem.
 
My wife's I phone paired with Bluetooth right away, paired and started the updates. It would say the update failed, restart the update. After 7 tries and 7 fails, shut it down and headed inside for a cocktail.

Thanks for the help and Merry Christmas !!
 
My wife's I phone paired with Bluetooth right away, paired and started the updates. It would say the update failed, restart the update. After 7 tries and 7 fails, shut it down and headed inside for a cocktail.

Thanks for the help and Merry Christmas !!
Sounds exactly like what I would do! After 2 or 3 I would then try a hard reset by holding down the 3 side buttons while cycling off to clear the memory...instruction are on internet and Weber site.
 
Sounds exactly like what I would do! After 2 or 3 I would then try a hard reset by holding down the 3 side buttons while cycling off to clear the memory...instruction are on internet and Weber site.
That was the answer, I am up and running. Thank you Dassman5 !!!
 
Back
Top