Smokefire won’t heat up

kurtographer

New member
Joined
Jan 7, 2024
Messages
2
Reaction score
0
Points
1
Location
Mayne Island BC
Grill
Smokefire
Hi everyone , can anyone help ?

-Brand new glow plug, and glow plug bracket
-updated software
- machine is clean
Hopper runs, and glow plug gets hot for a minute, but then cools off, and machine won’t heat up .
Any idea what causes this?

I’m about to send this thing back, it was really expensive, and my wife is not impressed.
 
I am experiencing a similar issue with my EPX4. The pellets are falling as expected, but the glow plug heats up and then stops working, without igniting the pellets. Initially, I thought that a new glow plug could fix the problem, but upon inspection, I found that a plastic bracket has melted, and it looks completely different from what everyone else has or what I can buy. I am confused about what this plastic bracket is and why I have something different from others.

EPX4 Pellet Grill, STEALTH Edition
 

Attachments

  • PXL_20240120_230207471.jpg
    PXL_20240120_230207471.jpg
    360.9 KB · Views: 16
  • PXL_20240120_230210581.jpg
    PXL_20240120_230210581.jpg
    299.1 KB · Views: 16
  • PXL_20240120_230224746.MP.jpg
    PXL_20240120_230224746.MP.jpg
    466.1 KB · Views: 16
  • PXL_20240120_225511974.jpg
    PXL_20240120_225511974.jpg
    385.8 KB · Views: 16
Hi everyone , can anyone help ?

-Brand new glow plug, and glow plug bracket
-updated software
- machine is clean
Hopper runs, and glow plug gets hot for a minute, but then cools off, and machine won’t heat up .
Any idea what causes this?

I’m about to send this thing back, it was really expensive, and my wife is not impressed.
Make sure the glow plug is seated really well. Some early users had issues with it losing contact. Many put metal hose clad on them to make it extra secure.
if you haven’t I‘d also contact Weber as they may send you some replacement parts. Possible the controller is bad.
 
Back
Top