Motor Failure (E7)

JB207

New member
Joined
Jul 10, 2023
Messages
3
Reaction score
0
Points
1
Location
Maine
Grill
SmokeFire+
Hello,
I have a new SmokeFire+ with a Motor Failure error on the screen and then it shuts down without even starting. I have been trying for 4 days to get a response from Weber with no luck. I went through the basic troubleshooting, removed back panel, checked connections, etc to no avail. I called the SmokeFire #, leave a message, email, with no response. The only response I get is from Facebook Messenger where they say someone will call me. It's one thing to have a new $1500 product die in the first couple of months, but to get completely ghosted on support is unconscionable.
I have been a Weber (gas grill) customer for over 25yrs and the reason I took a chance with the SmokeFire and boy do I regret it.
Screen shot of error message attached.
Thank you
 

Attachments

  • Screenshot 2023-07-10 at 3.11.11 PM.png
    Screenshot 2023-07-10 at 3.11.11 PM.png
    693 KB · Views: 140
Weber support has been on the fritz for availability for some time now, but they will respond and they will take care of you. Probably 24-48 hrs. Phone call is typically the fastest way to get someone, but as you have experienced, it can be a dead end.
I recall E7 coming up in a past thread, I don't recall the situation or solution. Try a search. Possible it is jammed with dust or the cotter pen \ screw broke. Both have been reported before. Once you take the back panel off, it is just 2 more screws and 1 wire connection to pull the auger and see what is going on. Empty the hopper first and expect to have a small amount of pellet come out with the auger.
 
Weber support has been on the fritz for availability for some time now, but they will respond and they will take care of you. Probably 24-48 hrs. Phone call is typically the fastest way to get someone, but as you have experienced, it can be a dead end.
I recall E7 coming up in a past thread, I don't recall the situation or solution. Try a search. Possible it is jammed with dust or the cotter pen \ screw broke. Both have been reported before. Once you take the back panel off, it is just 2 more screws and 1 wire connection to pull the auger and see what is going on. Empty the hopper first and expect to have a small amount of pellet come out with the auger.
Thank you for the information, I will give that a try.
 
Hello,
I have a new SmokeFire+ with a Motor Failure error on the screen and then it shuts down without even starting. I have been trying for 4 days to get a response from Weber with no luck. I went through the basic troubleshooting, removed back panel, checked connections, etc to no avail. I called the SmokeFire #, leave a message, email, with no response. The only response I get is from Facebook Messenger where they say someone will call me. It's one thing to have a new $1500 product die in the first couple of months, but to get completely ghosted on support is unconscionable.
I have been a Weber (gas grill) customer for over 25yrs and the reason I took a chance with the SmokeFire and boy do I regret it.
Screen shot of error message attached.
Thank you
It doesn't seem as much of a problem.
 
Not sure what that means, but once Weber finally responded, I returned the grill under the 100 day guarantee and it is no longer a problem for me.
 
Not sure what that means, but once Weber finally responded, I returned the grill under the 100 day guarantee and it is no longer a problem for me.
Back to wood fire cooking then?
Not much can go wrong there.
 
Got the E7 motor code error today and immediately googled. From the Weber site, can they actually be this silly and provide a page that doesn't display pictures correctly? https://consumer-care.weber.com/s/a...e=en_US#:~:text=Error Code E7 - Motor Failure

Either way, I took everything apart, cleaned to the best of my ability, even removed the cotter pin, put everything back together and the EX4 goes right back to E7 error. I assume this is a motor failure then? (I think I may be a month or two out of my warranty for my gen 2 unit)

Do they work with you at all here?
 
Got the E7 motor code error today and immediately googled. From the Weber site, can they actually be this silly and provide a page that doesn't display pictures correctly? https://consumer-care.weber.com/s/article/Error-Code-E7-Motor-Failure-1706747678543?language=en_US#:~:text=Error Code E7 - Motor Failure

Either way, I took everything apart, cleaned to the best of my ability, even removed the cotter pin, put everything back together and the EX4 goes right back to E7 error. I assume this is a motor failure then? (I think I may be a month or two out of my warranty for my gen 2 unit)

Do they work with you at all here?
$140 I hear.
 
$140 I hear.
Well, I'll be damn. 60 days outside warranty and I got a free replacement. I guess lucky today...

In my opinion however I can't say I feel great about the long term support for the Smokefire. In "somewhat" vague terms Weber accepted that the Smokefire was a failure and completely redesigned it releasing the Searwood. What possibly should have been offered to us would be a 1 time 50% upgrade to the Searwood since "soon" parts will most likely disappear from our version.
 
They seem to be pretty good at taking care of SmokeFire customers even after warranty at least so far. They sent me new motor outside of warranty as well. I voiced similar concerns to them about it already being discontinued and the longevity since I’ve had to replace a lot of parts already. Weber support said “We'd be supporting your grill and the other SmokeFire grills for years to come. A good example would be that we could sell a SmokeFire today from the remaining stock and it'd come with a 5 year warranty on the cookbox. So we'd have to have enough parts in case we need to assemble a new grill as a replacement, even years later.”
I probably would have taken a deal on a Searwood if they had offered but ended up getting a Recteq.
 
They seem to be pretty good at taking care of SmokeFire customers even after warranty at least so far. They sent me new motor outside of warranty as well. I voiced similar concerns to them about it already being discontinued and the longevity since I’ve had to replace a lot of parts already. Weber support said “We'd be supporting your grill and the other SmokeFire grills for years to come. A good example would be that we could sell a SmokeFire today from the remaining stock and it'd come with a 5 year warranty on the cookbox. So we'd have to have enough parts in case we need to assemble a new grill as a replacement, even years later.”
I probably would have taken a deal on a Searwood if they had offered but ended up getting a Recteq.
I could be wrong but the more I think about it, I think possibly the motor assembly qualifies under the 5 year warranty as I didn't see the motor listed under 3 year components.
 
They told me mine was out of warranty, so not sure. I purchased mine Feb 2020.
 
Hello,
I have a new SmokeFire+ with a Motor Failure error on the screen and then it shuts down without even starting. I have been trying for 4 days to get a response from Weber with no luck. I went through the basic troubleshooting, removed back panel, checked connections, etc to no avail. I called the SmokeFire #, leave a message, email, with no response. The only response I get is from Facebook Messenger where they say someone will call me. It's one thing to have a new $1500 product die in the first couple of months, but to get completely ghosted on support is unconscionable.
I have been a Weber (gas grill) customer for over 25yrs and the reason I took a chance with the SmokeFire and boy do I regret it.
Screen shot of error message attached.
Thank you
Happend to me, the auger shearpin broke, and yes there customer service is horrible
 
They told me mine was out of warranty, so not sure. I purchased mine Feb 2020.
6 days later, motor assembly apparently must be on back order, still can't use the grill. *Quickly, place Craigslist "for sale" post to recoup money buying analog Weber Smokey mountain 22". :rolleyes:
 
Hello,
I have a new SmokeFire+ with a Motor Failure error on the screen and then it shuts down without even starting. I have been trying for 4 days to get a response from Weber with no luck. I went through the basic troubleshooting, removed back panel, checked connections, etc to no avail. I called the SmokeFire #, leave a message, email, with no response. The only response I get is from Facebook Messenger where they say someone will call me. It's one thing to have a new $1500 product die in the first couple of months, but to get completely ghosted on support is unconscionable.
I have been a Weber (gas grill) customer for over 25yrs and the reason I took a chance with the SmokeFire and boy do I regret it.
Screen shot of error message attached.
Thank you
I have a new motherboard and auger and motor assembly, not even open, I got the new searwood If you give me an address to send it to you can have it for free
 

Latest Discussions

Back
Top